Posts

Do not update to macOS Catalina
,

Important Notice for DEX 3 Users | Do Not Update to macOS Catalina

Attention DEX 3 (all versions) and LYRX users: macOS Catalina (10.15) is not supported at this time.  If you upgrade to macOS Catalina you will be unable to properly launch DEX 3 (or LYRX). With Catalina, Apple has removed much of the OpenGL…