Back to Karaoki Support Forum
Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #16733

    dftweedie
    Participant

    Hi …
    The BGM bug popped up again in pcdj_karaoki_setup_0.8.6546. It drives me nuts that I can’t reliably use the back ground music.

    DF

    #16735

    Ryan Sherr
    Keymaster

    How do you mean ‘popped up again’? It was working fine and just started to not work? That would be extremely strange from a programming/logic stand point. Are you using the recommended BGM mode “pause and load next track”?

    #16737

    dftweedie
    Participant

    What I mean is that it seemed to be working fine for a couple of events and then seemingly spontaneously without changing any configuration it interrupted the music while a karaoke track was playing so that both audio streams were playing.

    No, I didn’t have the recommended settings configured, although I do now. I’ll trust you that this will prevent dual audio streams in the future.

    Thanks.

    #16739

    Ryan Sherr
    Keymaster

    Please let me know otherwise!

    #16741

    dftweedie
    Participant

    Ryan,

    One other clarification while we are at it … since I obviously know less about the BGM player than necessary!

    So, if I understand it is always playing once started unless the settings ‘pause and load next track’ option is selected.

    But is there anyway to have it stop and start the BGM player so that the paused song starts from the point where it was stopped by the karaoke music? I’ve heard this behavior in other KJ’s setups, but in Karaoki it seemed that the BGM track kept playing and the when the karaoke track ends the BGM music starts up further in the BGM track or maybe on a new song.

    I hope I am explaining this clearly enough. Do you understand what I am asking and is this possible?

    I am still a little perplexed as to why on the other settings the BGM audio stream should intrude on the karaoke music. This surely isn’t supposed to happen, is it?

    #16742

    Ryan Sherr
    Keymaster

    Yes, you can do this. Instead of enabling both Pause and Pause and load next track, just enable PAUSE. Do not also enable “load next track”. That way it will just pick up playing the same song where it left off when it kicks back in.

    This is the very first report I’ve seen of the BGM player kicking on while using ANY BGM playback mode in version 0.8.6546. From all other reports/support tickets it seems 0.8.6546 eliminated the issue. So I’m not quite sure what to make of it (yet).

    #16743

    dftweedie
    Participant

    Thanks again Ryan. I’ll keep you posted.

    DF

    #16951
    asotelo2007
    asotelo2007
    Participant

    I’m certain that the issues you are having with the BGM can be explained with the length of your shows. Thus why it only happens sometimes. It’s correlated to how long you have been running the BGM. In my experience, the BGM issue will still arise if there is not enough music loaded into the playlist. If the BGM begins replaying songs that it had played earlier in the night, it will start fading back in randomly. To fix this issue, I simply made a playlist that was over 6 hours long as my shows typically only last 5 hours. Hope this helps.

    #16952

    dftweedie
    Participant

    Thanks for your suggestion. So far so good … since enabling ‘Auto Pause’ I haven’t had any further glitch. It way be that Auto Pause expands the playlist as you suggest may help.

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.